iOS App: Latest version

The latest version of the iOS app is 1.9.0.

The Newsela app is only supported on devices that can run iOS 10 or greater. As a general rule, our app will only work on devices that can run the latest two full releases of iOS (in this case, 10 and 11). If the device can't install those versions of iOS, the app will not work on it. The reasoning here is if the devices can't support the latest versions of iOS, they definitely won't be able to support the increased functionality that we have on the app. 

 

Let’s Talk

Please provide your information below, and a member of our team will call you right back. Available during the business hours of 8am–7pm ET